Añadir clave GPG a RPM para verificar paquetes

Categorías: Administración de sistemas Empaquetado de software Seguridad

Recientemente, al actualizar el paquete google-talkplugin, recibía este error:

Error grave: package google-talkplugin-5.41.3.0-1.x86_64 cannot be verified and repo google-talkplugin is GPG enabled: failed to lookup digest in keyring for /var/cache/PackageKit/24/metadata/google-talkplugin/packages/google-talkplugin-5.41.3.0-1.x86_64.rpm

Diciéndome, básicamente, que no se puede verificar el paquete porque no se dispone de la clave pública que se usó para firmarlo.

Lee Mas →

Añadir la clave pública de Google a DNF

Categorías: Administración de sistemas Empaquetado de software Encriptación GNU/Linux

Google tiene repositorios para Linux, y usa una clave GPG para firmar los paquetes. Si no la tienes instalada, tendrás problemas al actualizar, como me pasaba a mí recientemente:

$ pkcon install google-talkplugin
Error grave: package google-talkplugin-5.41.3.0-1.x86_64 cannot be verified and repo google-talkplugin is GPG enabled: failed to lookup digest in keyring for /var/cache/PackageKit/metadata/google-talkplugin/packages/google-talkplugin-5.41.3.0-1.x86_64.rpm

Lee Mas →