Problemas de sonido en Debian

Categorías: Audio GNU/Linux

Con mi iniciación en Debian, me he topado con un problema bastante fastidioso: no conseguía grabar sonido.
Investigando descubrí otros 2 problemas relacionados con el sonido: que al grabar con la webcam usando Cheese grababa como a 2 FPS, y que no podía tener varias aplicaciones usando sonido simultáneamente.
Bueno, tras mucho googlear y pelear con el ordenador, he encontrado la solución. Parece ser que es un problema con ALSA, el sistema de sonido que suele usar Linux (algo más nuevo que el antiguo OSS, aunque éste aún está en uso).
La solución es usar el servidor de sonido PulseAudio, que si no me equivoco, se encarga de gestionar las conexiones con ALSA. No sé si esto es cierto al 100%, pero desde luego ahora funciona.
Para instalarlo:

# aptitude install pulseaudio paprefs

Pulseaudio es el metapaquete, paprefs es la interfaz en GTK. Ahora os explicaré cómo configurarlo en Gnome.
Una vez instalados los paquetes, iremos a configurar los dispositivos de entrada en Sistema > Preferencias > Selector de sistemas multimedia, o por consola:

gstreamer-properties

Aquí elegiremos como complementos de salida y entrada de audio PulseAudio Sound Server.
Cerremos todas las aplicaciones que estén usando audio, y las abrimos de nuevo. Bueno, no sé si esto es estrictamente necesario, pero bueno. Por si acaso, si lo prefieres, cierra la sesión y ábrela de nuevo. Todos los problemas anteriormente mencionados se arreglarán.
Queda la salvedad de Cheese, que probablemente siga grabándote lento. Ya explicaré esto otro día.
Edito: Aquí va un artículo muy interesante hablando sobre la instalación de PulseAudio.

Ver también

Comentarios

comments powered by Disqus